#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(\d+\.?\s*)?(?<place_type>int|ext|est)\.?\s*(?<place>.*?)\s+-\s+(?<when>.*?)\s*$"
Local $sString = "EXT. PUB - NIGHT" & @CRLF & _
"4. INT. Bedroom - night" & @CRLF & _
"EXT Garden - morning" & @CRLF & _
"ext. Garden - midday " & @CRLF & _
"2. INT. Kitchen - evening" & @CRLF & _
"1 Ext By the lake - night" & @CRLF & _
"10. int. In bed - night"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")