package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^(\d+\.?\s*)?(?<place_type>int|ext|est)\.?\s*(?<place>.*?)\s+-\s+(?<when>.*?)\s*$`)
var str = `EXT. PUB - NIGHT
4. INT. Bedroom - night
EXT Garden - morning
ext. Garden - midday
2. INT. Kitchen - evening
1 Ext By the lake - night
10. int. In bed - night`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}