use strict;
my $str = 'EXT. PUB - NIGHT
4. INT. Bedroom - night
EXT Garden - morning
ext. Garden - midday
2. INT. Kitchen - evening
1 Ext By the lake - night
10. int. In bed - night';
my $regex = qr/^(\d+\.?\s*)?(?<place_type>int|ext|est)\.?\s*(?<place>.*?)\s+-\s+(?<when>.*?)\s*$/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}