import re
regex = re.compile(r"^(\d+\.?\s*)?(?<place_type>int|ext|est)\.?\s*(?<place>.*?)\s+-\s+(?<when>.*?)\s*$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("EXT. PUB - NIGHT\n"
"4. INT. Bedroom - night\n"
"EXT Garden - morning\n"
"ext. Garden - midday \n"
"2. INT. Kitchen - evening\n"
"1 Ext By the lake - night\n"
"10. int. In bed - night")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")