$re = '/^(\d+\.?\s*)?(?<place_type>int|ext|est)\.?\s*(?<place>.*?)\s+-\s+(?<when>.*?)\s*$/mi';
$str = 'EXT. PUB - NIGHT
4. INT. Bedroom - night
EXT Garden - morning
ext. Garden - midday
2. INT. Kitchen - evening
1 Ext By the lake - night
10. int. In bed - night';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);