using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(CJ2\d)_V2r";
string substitution = @"$1r_V2";
string input = @"CJ21_V2r
CJ22_V2r";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}