package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(CJ2\d)_V2r`)
var str = `CJ21_V2r
CJ22_V2r`
var substitution = "$1r_V2"
fmt.Println(re.ReplaceAllString(str, substitution))
}