$re = '/(CJ2\d)_V2r/m';
$str = 'CJ21_V2r
CJ22_V2r';
$subst = "$1r_V2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;