import re
regex = re.compile(r"(CJ2\d)_V2r", flags=re.MULTILINE)
test_str = ("CJ21_V2r \n"
"CJ22_V2r")
subst = "$1r_V2"
result = regex.sub(subst, test_str)
if result:
print(result)