use strict;
my $str = 'CJ21_V2r
CJ22_V2r';
my $regex = qr/(CJ2\d)_V2r/mp;
my $subst = '$1r_V2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";