#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\w{2,}\s\s*)*(\w{2,})$"
Local $sString = "city, country" & @CRLF & _
"ok, city,country," & @CRLF & _
"n, foo, bar" & @CRLF & _
"foo, bar, n" & @CRLF & _
",foo, bar, test" & @CRLF & _
"foo,bar" & @CRLF & _
"foobar"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")