$re = '/^(\w{2,}\s\s*)*(\w{2,})$/m';
$str = 'city, country
ok, city,country,
n, foo, bar
foo, bar, n
,foo, bar, test
foo,bar
foobar';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);