import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\w{2,}\\s\\s*)*(\\w{2,})$";
final String string = "city, country\n"
+ "ok, city,country,\n"
+ "n, foo, bar\n"
+ "foo, bar, n\n"
+ ",foo, bar, test\n"
+ "foo,bar\n"
+ "foobar";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}