using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\w{2,}\s\s*)*(\w{2,})$";
string input = @"city, country
ok, city,country,
n, foo, bar
foo, bar, n
,foo, bar, test
foo,bar
foobar";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}