re = /^(\w{2,}\s\s*)*(\w{2,})$/m
str = 'city, country
ok, city,country,
n, foo, bar
foo, bar, n
,foo, bar, test
foo,bar
foobar'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end