#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.{10,}$)(?=.*?[A-Z].*?[A-Z])(?=.*?([\x20-\x40\x5b-\x60\x7b-\x7e\x80-\xbf]).*?(?1).*?$).*$"
Local $sString = "alsjkdhDflkalskjdf;klGasdf" & @CRLF & _
"" & @CRLF & _
"akjsdhf" & @CRLF & _
"" & @CRLF & _
"asdfas;;jhbsHHHJHdd" & @CRLF & _
"" & @CRLF & _
"A3425cf2345Wcc2345vcdf" & @CRLF & _
"" & @CRLF & _
"sdJIOJjhhhgiuufk" & @CRLF & _
"" & @CRLF & _
"@::}}@}@}IHKJHKJ88ujjj" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"ssss" & @CRLF & _
"" & @CRLF & _
"ss11!S"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")