use strict;
my $str = 'alsjkdhDflkalskjdf;klGasdf
akjsdhf
asdfas;;jhbsHHHJHdd
A3425cf2345Wcc2345vcdf
sdJIOJjhhhgiuufk
@::}}@}@}IHKJHKJ88ujjj
ssss
ss11!S';
my $regex = qr/^(?=.{10,}$)(?=.*?[A-Z].*?[A-Z])(?=.*?([\x20-\x40\x5b-\x60\x7b-\x7e\x80-\xbf]).*?(?1).*?$).*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}