import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.{10,}$)(?=.*?[A-Z].*?[A-Z])(?=.*?([\\x20-\\x40\\x5b-\\x60\\x7b-\\x7e\\x80-\\xbf]).*?(?1).*?$).*$";
final String string = "alsjkdhDflkalskjdf;klGasdf\n\n"
+ "akjsdhf\n\n"
+ "asdfas;;jhbsHHHJHdd\n\n"
+ "A3425cf2345Wcc2345vcdf\n\n"
+ "sdJIOJjhhhgiuufk\n\n"
+ "@::}}@}@}IHKJHKJ88ujjj\n\n\n"
+ "ssss\n\n"
+ "ss11!S";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}