using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.{10,}$)(?=.*?[A-Z].*?[A-Z])(?=.*?([\x20-\x40\x5b-\x60\x7b-\x7e\x80-\xbf]).*?(?1).*?$).*$";
string input = @"alsjkdhDflkalskjdf;klGasdf
akjsdhf
asdfas;;jhbsHHHJHdd
A3425cf2345Wcc2345vcdf
sdJIOJjhhhgiuufk
@::}}@}@}IHKJHKJ88ujjj
ssss
ss11!S";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}