const regex = /^(?=.{10,}$)(?=.*?[A-Z].*?[A-Z])(?=.*?([\x20-\x40\x5b-\x60\x7b-\x7e\x80-\xbf]).*?(?1).*?$).*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.{10,}$)(?=.*?[A-Z].*?[A-Z])(?=.*?([\\x20-\\x40\\x5b-\\x60\\x7b-\\x7e\\x80-\\xbf]).*?(?1).*?$).*$', 'gm')
const str = `alsjkdhDflkalskjdf;klGasdf
akjsdhf
asdfas;;jhbsHHHJHdd
A3425cf2345Wcc2345vcdf
sdJIOJjhhhgiuufk
@::}}@}@}IHKJHKJ88ujjj
ssss
ss11!S`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}