#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\w*[0-9]+)\w*$"
Local $sString = "R3KEE" & @CRLF & _
"RK3DSW" & @CRLF & _
"RN80OW" & @CRLF & _
"R800U" & @CRLF & _
"7Q5RU" & @CRLF & _
"R2023NY" & @CRLF & _
"3DA0AQ" & @CRLF & _
"RW6APC" & @CRLF & _
"R7FQ" & @CRLF & _
"4X52A" & @CRLF & _
"4J6A" & @CRLF & _
"PY7AB" & @CRLF & _
"ROMAN 36 RAKITIN" & @CRLF & _
"ROMAN36RAKITIN" & @CRLF & _
"RAEM" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")