import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\w*[0-9]+)\\w*$";
final String string = "R3KEE\n"
+ "RK3DSW\n"
+ "RN80OW\n"
+ "R800U\n"
+ "7Q5RU\n"
+ "R2023NY\n"
+ "3DA0AQ\n"
+ "RW6APC\n"
+ "R7FQ\n"
+ "4X52A\n"
+ "4J6A\n"
+ "PY7AB\n"
+ "ROMAN 36 RAKITIN\n"
+ "ROMAN36RAKITIN\n"
+ "RAEM\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}