// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\w*[0-9]+)\w*$").unwrap();
let string = "R3KEE
RK3DSW
RN80OW
R800U
7Q5RU
R2023NY
3DA0AQ
RW6APC
R7FQ
4X52A
4J6A
PY7AB
ROMAN 36 RAKITIN
ROMAN36RAKITIN
RAEM
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}