# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(\w*[0-9]+)\w*$"
test_str = ("R3KEE\n"
"RK3DSW\n"
"RN80OW\n"
"R800U\n"
"7Q5RU\n"
"R2023NY\n"
"3DA0AQ\n"
"RW6APC\n"
"R7FQ\n"
"4X52A\n"
"4J6A\n"
"PY7AB\n"
"ROMAN 36 RAKITIN\n"
"ROMAN36RAKITIN\n"
"RAEM\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.