$re = '/^(\w*[0-9]+)\w*$/m';
$str = 'R3KEE
RK3DSW
RN80OW
R800U
7Q5RU
R2023NY
3DA0AQ
RW6APC
R7FQ
4X52A
4J6A
PY7AB
ROMAN 36 RAKITIN
ROMAN36RAKITIN
RAEM
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);