import Foundation
let pattern = #"^(\w*[0-9]+)\w*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
R3KEE
RK3DSW
RN80OW
R800U
7Q5RU
R2023NY
3DA0AQ
RW6APC
R7FQ
4X52A
4J6A
PY7AB
ROMAN 36 RAKITIN
ROMAN36RAKITIN
RAEM
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)