#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([a-z][a-z0-9_-]*?[^-_]|[a-z]+)$"
Local $sString = "Examples of matching strings:" & @CRLF & _
"a" & @CRLF & _
"a-b" & @CRLF & _
"ab_c--de" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Examples of non-matching strings:" & @CRLF & _
"a-" & @CRLF & _
"abc-" & @CRLF & _
"a_" & @CRLF & _
"-"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")