$re = '/^([a-z][a-z0-9_-]*?[^-_]|[a-z]+)$/m';
$str = 'Examples of matching strings:
a
a-b
ab_c--de
Examples of non-matching strings:
a-
abc-
a_
-';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);