using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([a-z][a-z0-9_-]*?[^-_]|[a-z]+)$";
string input = @"Examples of matching strings:
a
a-b
ab_c--de
Examples of non-matching strings:
a-
abc-
a_
-";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}