re = /^([a-z][a-z0-9_-]*?[^-_]|[a-z]+)$/m
str = 'Examples of matching strings:
a
a-b
ab_c--de
Examples of non-matching strings:
a-
abc-
a_
-'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end