import re
regex = re.compile(r"^([a-z][a-z0-9_-]*?[^-_]|[a-z]+)$", flags=re.MULTILINE)
test_str = ("Examples of matching strings:\n"
"a\n"
"a-b\n"
"ab_c--de\n\n\n"
"Examples of non-matching strings:\n"
"a-\n"
"abc-\n"
"a_\n"
"-")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")