import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([a-z][a-z0-9_-]*?[^-_]|[a-z]+)$";
final String string = "Examples of matching strings:\n"
+ "a\n"
+ "a-b\n"
+ "ab_c--de\n\n\n"
+ "Examples of non-matching strings:\n"
+ "a-\n"
+ "abc-\n"
+ "a_\n"
+ "-";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}