# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\[note\])((?:(?!\[\\/note\]|\[place\])(?:.|[\r\n]))*)(?:(\[place\])((?:(?!\[\\/place\])(?:.|[\r\n]))*)(\[\\/place\]))((?:(?!\[\\/note\])(?:.|[\r\n]))*)(\[\\/note\])//g;t' <<< "å°æ˜Žåœ¨[place]å°ç£[/place]耶,[note]å°æ˜Žåœ¨[place]å°åŒ—[/place]çš„
[place]å—æ¸¯[/place]附近[/note],然後å°çŽ‹ä¹Ÿåœ¨[place]å°ç£[/place],
[note]å°çŽ‹åœ¨[place]高雄[/place][/note],兩人è·é›¢å¾ˆé 。
[note][place][/place][/note]"