import Foundation
let pattern = #"(\[note\])((?:(?!\[\/note\]|\[place\])(?:.|[\r\n]))*)(?:(\[place\])((?:(?!\[\/place\])(?:.|[\r\n]))*)(\[\/place\]))((?:(?!\[\/note\])(?:.|[\r\n]))*)(\[\/note\])"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
å°æ˜Žåœ¨[place]å°ç£[/place]耶,[note]å°æ˜Žåœ¨[place]å°åŒ—[/place]çš„
[place]å—æ¸¯[/place]附近[/note],然後å°çŽ‹ä¹Ÿåœ¨[place]å°ç£[/place],
[note]å°çŽ‹åœ¨[place]高雄[/place][/note],兩人è·é›¢å¾ˆé 。
[note][place][/place][/note]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)