const regex = /(\[note\])((?:(?!\[\/note\]|\[place\])(?:.|[\r\n]))*)(?:(\[place\])((?:(?!\[\/place\])(?:.|[\r\n]))*)(\[\/place\]))((?:(?!\[\/note\])(?:.|[\r\n]))*)(\[\/note\])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\[note\\])((?:(?!\\[\\\/note\\]|\\[place\\])(?:.|[\\r\\n]))*)(?:(\\[place\\])((?:(?!\\[\\\/place\\])(?:.|[\\r\\n]))*)(\\[\\\/place\\]))((?:(?!\\[\\\/note\\])(?:.|[\\r\\n]))*)(\\[\\\/note\\])', 'g')
const str = `å°æ˜Žåœ¨[place]å°ç£[/place]耶,[note]å°æ˜Žåœ¨[place]å°åŒ—[/place]çš„
[place]å—æ¸¯[/place]附近[/note],然後å°çŽ‹ä¹Ÿåœ¨[place]å°ç£[/place],
[note]å°çŽ‹åœ¨[place]高雄[/place][/note],兩人è·é›¢å¾ˆé 。
[note][place][/place][/note]`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);