#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(\[note\])((?:(?!\[\/note\]|\[place\])(?:.|[\r\n]))*)(?:(\[place\])((?:(?!\[\/place\])(?:.|[\r\n]))*)(\[\/place\]))((?:(?!\[\/note\])(?:.|[\r\n]))*)(\[\/note\])"
Local $sString = "å°æ˜Žåœ¨[place]å°ç£[/place]耶,[note]å°æ˜Žåœ¨[place]å°åŒ—[/place]çš„" & @CRLF & _
"[place]å—æ¸¯[/place]附近[/note],然後å°çŽ‹ä¹Ÿåœ¨[place]å°ç£[/place]," & @CRLF & _
"[note]å°çŽ‹åœ¨[place]高雄[/place][/note],兩人è·é›¢å¾ˆé 。" & @CRLF & _
"" & @CRLF & _
"[note][place][/place][/note]"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)