import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\[note\\])((?:(?!\\[\\/note\\]|\\[place\\])(?:.|[\\r\\n]))*)(?:(\\[place\\])((?:(?!\\[\\/place\\])(?:.|[\\r\\n]))*)(\\[\\/place\\]))((?:(?!\\[\\/note\\])(?:.|[\\r\\n]))*)(\\[\\/note\\])";
final String string = "å°æ˜Žåœ¨[place]å°ç£[/place]耶,[note]å°æ˜Žåœ¨[place]å°åŒ—[/place]çš„\n"
+ "[place]å—æ¸¯[/place]附近[/note],然後å°çŽ‹ä¹Ÿåœ¨[place]å°ç£[/place],\n"
+ "[note]å°çŽ‹åœ¨[place]高雄[/place][/note],兩人è·é›¢å¾ˆé 。\n\n"
+ "[note][place][/place][/note]";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}