using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\[note\])((?:(?!\[\/note\]|\[place\])(?:.|[\r\n]))*)(?:(\[place\])((?:(?!\[\/place\])(?:.|[\r\n]))*)(\[\/place\]))((?:(?!\[\/note\])(?:.|[\r\n]))*)(\[\/note\])";
string substitution = @"";
string input = @"å°æ˜Žåœ¨[place]å°ç£[/place]耶,[note]å°æ˜Žåœ¨[place]å°åŒ—[/place]çš„
[place]å—æ¸¯[/place]附近[/note],然後å°çŽ‹ä¹Ÿåœ¨[place]å°ç£[/place],
[note]å°çŽ‹åœ¨[place]高雄[/place][/note],兩人è·é›¢å¾ˆé 。
[note][place][/place][/note]";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}