# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\\/\*.*?\*\\/|\\/\\/.*?\n//gs;t' <<< "asfasdf
/** This comment gets removed with my regex */
asdfasdf asdf asdf
/** This comment gets
removed with my regex */
asdfasdf asdf asdf
// ** This comment has the double leadng-trailng slashes ** //
asdfasdf
afasfsdf"