package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)\/\*.*?\*\/|\/\/.*?\n`)
var str = `asfasdf
/** This comment gets removed with my regex */
asdfasdf asdf asdf
/** This comment gets
removed with my regex */
asdfasdf asdf asdf
// ** This comment has the double leadng-trailng slashes ** //
asdfasdf
afasfsdf`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}