#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?s)\/\*.*?\*\/|\/\/.*?\n"
Local $sString = "asfasdf" & @CRLF & _
"/** This comment gets removed with my regex */" & @CRLF & _
"asdfasdf asdf asdf" & @CRLF & _
"/** This comment gets " & @CRLF & _
"removed with my regex */" & @CRLF & _
"asdfasdf asdf asdf" & @CRLF & _
"// ** This comment has the double leadng-trailng slashes ** //" & @CRLF & _
"asdfasdf" & @CRLF & _
"afasfsdf"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)