// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?s)\/\*.*?\*\/|\/\/.*?\n").unwrap();
let string = "asfasdf
/** This comment gets removed with my regex */
asdfasdf asdf asdf
/** This comment gets
removed with my regex */
asdfasdf asdf asdf
// ** This comment has the double leadng-trailng slashes ** //
asdfasdf
afasfsdf";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}