re = /\/\*.*?\*\/|\/\/.*?\n/
str = 'asfasdf
/** This comment gets removed with my regex */
asdfasdf asdf asdf
/** This comment gets
removed with my regex */
asdfasdf asdf asdf
// ** This comment has the double leadng-trailng slashes ** //
asdfasdf
afasfsdf'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result