use strict;
my $str = 'asfasdf
/** This comment gets removed with my regex */
asdfasdf asdf asdf
/** This comment gets
removed with my regex */
asdfasdf asdf asdf
// ** This comment has the double leadng-trailng slashes ** //
asdfasdf
afasfsdf';
my $regex = qr/\/\*.*?\*\/|\/\/.*?\n/sp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";