# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?!^)(\[[A-Z].*?\]\[\d+\])//gm;t' <<< "[Some Text][1][Some [] Text][2]"