use strict;
my $str = '[Some Text][1][Some [] Text][2]';
my $regex = qr/(?!^)(\[[A-Z].*?\]\[\d+\])/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";