import re
regex = re.compile(r"(?!^)(\[[A-Z].*?\]\[\d+\])", flags=re.MULTILINE)
test_str = "[Some Text][1][Some [] Text][2]"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)