$re = '/(?!^)(\[[A-Z].*?\]\[\d+\])/m';
$str = '[Some Text][1][Some [] Text][2]';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;