const regex = /(?!^)(\[[A-Z].*?\]\[\d+\])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?!^)(\\[[A-Z].*?\\]\\[\\d+\\])', 'gm')
const str = `[Some Text][1][Some [] Text][2]`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);