re = /(?!^)(\[[A-Z].*?\]\[\d+\])/m
str = '[Some Text][1][Some [] Text][2]'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result